I, Librarian 5.0 released

Published on Fri, 17 Apr 2020 17:15:30 -0500

Our servers now run a new, much improved version of I, Librarian.

A few months late, but it's finally here. We are proud to announce our service now runs I, Librarian 5! Below are some of the new or improved features.

User interface

  • Redesigned UI, which is easier to get around, more consistent, and fully responsive to the device width and resolution.
  • Two new UI themes — light and dark (perfect for working in dimmed light).
  • New dashboard, which gives quick access to the search, latest items, notes and discussions.
  • New import UI, which guides users to the best way to upload papers.

Search

  • Integrated search of Arxiv, Crossref, IEEE, NASA, PubMed, PubMed Central, Scopus, and over a 100 million world-wide patent database.
  • Faster quick, and advanced search of metadata and PDFs with faceting and detailed highlighted snippets. The search is diacritics-neutral in hundreds of languages, based on the UTF-8 folding rules. Our new search is powered by Apache Solr.

PDF viewer

  • Greatly improved PDF viewer now renders pages in vector graphics for uncompromising quality.
  • Streamlined toolbar.
  • We added a multicolored marker.
  • Night mode converts pages to black background and white text.

Other improvements

  • Much improved Project management, with open and restricted access, user groups, and project-specific notes.
  • A new catalog, which enables browsing hundreds of thousands of items based on ID.
  • A new, accurate OCR supports over 90 languages.

Central management

  • New user activity logs, which show details about how many items and PDF pages each user read and more.
  • Much improved user management, which enables suspending and deleting users, resetting their password, etc.
  • Improved LDAP authentication, which now support TLS.
  • New SAML2 IdP initiated single sign-on authentication with group authorization.

Technical improvements

  • Everything was completely rewritten to get rid of the ancient PHP 4 code. We now use PHP 7.2.
  • Better protection from all those pesky CSRF, XSS, SSRF, ACE, and SQL injection attacks.
  • We adapted the semantic versioning, so all 5.X.X versions will be forward and backward compatible. If we break compatibility, we will bump the major version.



If you are subscribed for our service, your library always runs the newest version.

Subscribe now!

If you self-host I, Librarian, it is easy to move your existing library to our servers. Just subscribe and let our support know you want to upload your library. We will be happy to help you!

comments powered by Disqus